
User guide for Automatic Guided Vehicle

simulation

DRAFT v0.1
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Abstract

This document contains some background information and the User
Guide for the AGV simulation project.
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1 Introduction

In this document you can find information about the second version of the
Automatic Guided Vehicle (AGV) simulation [1] originally developed by the
AgentWise taskforce of the DistriNet [4] Lab at the KULeuven1. The simulator
was developed to provide infrastructure to students and researchers for applying
ideas into a simulation of a real world case. Now, the AGV-simulation code is
made Open Source under the GNU Public Licence [6] to permit others use this
ideas and to contribute to the AGV-simulation itself.

2 The Automatic Guided Vehicle case

TODO

3 Architecture

TODO

3.1 CVS projects

agentwise.agvsimulation A eclipse project containing the AGV-simulation
itself. Checkout this project if you want to run batch sim-
ulation. This project uses external jars and configurations for
specifying behavior. An example behavior can be found in
agentwise.agvsimulation.behaviordemo.

agentwise.agvsimulation.behaviordemo The project containing a demo
how to specify the behavior for the simulation. This is the project where
most extensions will happen.

agentwise.agvsimulation.ui The eclipse project containing a plug-in for: (1)
Editing XML files; (2) Visualizing the simulation. REMARK: unfin-
ished. Editor works well, except for the Outline view and circle segments.
Visualization is currently under development.

agentwise.agvsimulation.ui.feature The eclipse project containing the fea-
ture for the agentwise.agvsimulation.ui. Only needed for creating the
update site, not for developing the plug-in itself.

agentwise.agvsimulation.ui.update The eclipse project containing the up-
date site for the agentwise.agvsimulation.ui.feature. Only needed
to create the update site, not for developing the plug-in itself.

agentwise.agvsimulation.doc The documentation associated with this
project. Also contains the latest version of this User Guide.

1The previous version can be found on [2]
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4 Installation

Currently, Eclipse 3.1[5] with the AJDT plug-in[3], the GEF plug-in[7] on top
of java 1.5[8] are being used as development platform for the AGV simulation.
All these tools must be installed before continuing with this installation guide.
Information on how to installing these tools can be found on there respective
web sites. All projects in the CVS repository are eclipse projects, thus the use
of Eclipse for development is largely encouraged (and tested).

There are two ways in which this simulator can be used. Further on through
the instruction for installation and using the simulator we will refer to this uses.

Adapting behavior Only the behavior of the agents in the simulator is
adapted. The simulation is only used to execute this behavior (currently
only batch runs are supported).

Extending the simulator For making extensions to the simulator itself, to
the layout editor or to the visualization.

4.1 Installation for adapting behavior

For adapting the behavior of the AGV-agent, only anonymous access to the
SourceForge cvs servers is required. You’ll need to install the plug-in and check-
out two projects from cvs servers:

agentwise.agvsimulation This project is only needed to run the simulation.
It can be parameterized with both behavior (jar file) and a layout (specified
in an XML file).

agentwise.agvsimulation.behaviordemo This is an example project show-
ing how such an extension has to be build.

Remark that changes to these projects cannot be committed to the cvs server.
For thesis students: please DO NOT alter the agentwise.agvsimulation project.
If changes need to be made, you can signal this by submitting bug reports,
patches, etc. If you really need to extend the simulator itself, ask your assistant
for developers access to the repository (see4.2).

4.1.1 Anonymous checkout from SourceForge in Eclipse

• File→ New→ Other

• CVS→ Checkout project form CVS→ Next

• Create a new repository location

• Fill in the data and press Next (see Figure 1)

Host: cvs.sourceforge.net
Repository path: /cvsroot/agvsimulation/
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User: anonymous
Connection Type: pserver
(for more information see sourceforge website)

• Select Use an existing module, select the modules agent-
wise.agvsimulation and agentwise.agvsimulation.behaviordemo and
press Finish

• Sometimes you’ll get strange compilation errors because of the dependen-
cies between the projects. Some strategies to get them away are: (1) Close
and reopen the projects; (2) Clean the project (Project→ Clean...); (3)
Close and reopen eclipse.

4.1.2 Initial installation of the AGV simulation plug-in

• Help→ Software Updates→ Find and Install

• Choose for: Search for new features to install

• Add a new remote site with the url:
http://agvsimulation.sourceforge.net/updatesite/

• Select only the new remote site and press Finish

• ...The remainder of the wizard is trivial...

4.1.3 Updating the AGV simulation plug-in

• Help→ Software Updates→ Manage configuration

• Search for the agentwise.agvsimulation.ui.feature.* and select it

• press Scan for updates

• ...The remainder of the wizard is trivial...

4.2 Installation for extending the simulator

For extending the simulator itself you’ll need developers access to the cvs repos-
itory. Ask for it by using the appropriate procedure on the AGV Simulation
SourceForge website[1]. Please only submit code to the repository that
completely compiles, works and has been tested.

For thesis students: first ask your assistant if developers access is really
needed. If you get developers access and your are planning to make an extension,
please make a new branch for this extensions and use the appropriate package
names. Ones the extension is considered to be stable, it can be merged with the
HEAD branch of the repository.
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Figure 1: Screen shot of specifying the cvs server
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You’ll need to checkout the projects you want to extend using your Source-
Forge account details (see SourceForge website for more information about ob-
taining an account).

4.2.1 Developers checkout from SourceForge in Eclipse

• File→ New→ Other

• CVS→ Checkout project form CVS and press Next

• Create a new repository location

• Fill in the data and press Next

Host: cvs.sourceforge.net
Repository path: /cvsroot/agvsimulation/
User: *** your username ***
Connection Type: extssh
(for more information see sourceforge website)

• Use an existing module

• Select the projects you need (select them based on the description in 3.1)
and press Finish

5 Using and running

This section describes how to run the batch simulation and how to make a
project to describe the additional behavior.

5.1 Running the batch simulation

The simulation can be started from the command line or within the eclipse
environment. Here we describe how it can be started from within Eclipse.

5.1.1 AGV Batch Simulation: First run

First we will just try to start the simulation (without specifying parameters).

• Run→ Run...

• Right click on Aspect/Java application and select New

• Choose the correct project (agentwise.agvsimulation) and fill in the
correct Main class (agentwise.agvsimulation.BatchAgvSimulation).

• First press Apply, next press Run
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–layoutfile -l The layoutfile to use for the simulation.
–behaviorjar -j The jar file containing the code for agent behavior.
–behavioragv -b The class (in the behaviorjar) containing the behavior for the AGV.
–logconfig -c The XML file containing the configuration of the logger.
–timesteps -t Number of timesteps the simulation will run.

Table 1: The parameters for the AGV Batch Simulation

Normally you should get some output like this:

INFO - Effect applied: DriveToPositionEffect on AGV robot agv1: new position: Position(x=150.0meter,y=50.0meter)
INFO - Effect applied: ChangeEnergyEffect on AGV robot agv1: new energy level: 81.0v
INFO - Effect applied: DriveToPositionEffect on AGV robot agv1: new position: Position(x=150.0meter,y=150.0meter)
INFO - Effect applied: ChangeEnergyEffect on AGV robot agv1: new energy level: 31.0v
INFO - Effect applied: DriveToPositionEffect on AGV robot agv1: new position: Position(x=88.0meter,y=150.0meter)
INFO - Effect applied: ChangeEnergyEffect on AGV robot agv1: new energy level: 0.0v

Don’t forget to terminate the simulation before starting another
simulation, otherwise you’ll get strange errors.

5.1.2 Application parameters

Example parameters to use the demo behavior specified in
agentwise.agvsimulation.behaviordemo:

- l XML/layout.xml
- j ../agentwise.agvsimulation.behaviordemo/

agentwise_agvsimulation_behaviordemo.jar
-b agentwise.agvsimulation.behaviordemo.AGVRandomWalkBehavior
--logconfig ../agentwise.agvsimulation.behaviordemo/logconfig.xml
-t 300

With this parameters, the output should be something like:

INFO - Effect applied: DriveToPositionEffect on AGV robot agv1: new position: Position(x=150.0meter,y=50.0meter)
INFO - Effect applied: ChangeEnergyEffect on AGV robot agv1: new energy level: 81.0v
INFO - Effect applied: DriveToPositionEffect on AGV robot agv1: new position: Position(x=150.0meter,y=150.0meter)
INFO - Effect applied: ChangeEnergyEffect on AGV robot agv1: new energy level: 31.0v

5.1.3 Specifying parameters in eclipse

• Run→ Run...

• Select the your project

• Select the tab Arguments

• Fill in the arguments and press Apply (see figure 2).
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Figure 2: Screen shot of how to specify parameters

5.2 Making your own behavior: Action plan

1. First make a new project for your specific behavior (please do not use the
behaviordemo, it is only made for demo purpose).

For thesis students: put this project into a CVS repository, both for
backup as for version changes reasons.

• File→ New→ AspectJ Project

• Use as project name: yourname.agvsimulation

• Set the Create separate source and output folder option and
press Finish

• Go to the project properties, the AspectJ tab and fill in the output
jar for this project (e.g. yourname agvsimulation.jar)

2. Add a reference to the logger we are using:

• Make a new directory libs in your project

• Copy the jarfile for logging from the demo project, under folder ”libs”,
using a File Browser (outside exlipse). Afterwards press F5 to see the
jar file in the directory libs (within the package explorer).
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Figure 3: Screen shot of the build configuration

• Add this jar to the build path: Right click(on the jar file)→ Build
Path→ Add to build path.

• Copy the log configuration file from the demo project into your
project (edit this file later on if you want to enable/disable loggers).

3. Add the agentwise agvsimulation.jar to the build path of your project:
Project properties→ Java Build Path→ Libraries, next Add Jar
and add you find under agentwise.agvsimulation (should look like figure
3).

4. Make a new package with the name: your-
name.agvsimulation.agv.behavior

5. Make a new class in this package with the name AGVBehaviour, extending
from AGVBehaviour

6. Put some behavior in it (maybe copy the random walk behavior)...

7. Change the parameters of the simulator to refer to this new jarfile, log
configuration, ...

-j ../yourname.agvsimulation/yourname_agvsimulation.jar
-b agentwise.agvsimulation.behaviordemo.AGVTestBehaviour
--logconfig ../yourname.agvsimulation/logconfig.xml
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5.3 Making your own layout: Action plan

In order to do this, the AGV Simulation plug-in must be properly installed.

1. Make a new directory in you project called layouts

2. Right click on this directory and select New→ Other and choose for
Other→ AGV Simulation Layout.

3. Make your layout and save it.

4. Adapt the layout file parameter for the simulation to this new file:

- l ../yourname.agvsimulation/layouts/yourlayout.agvs

6 Extending the simulation

TODO: This section must still be written.

7 Additional information

For additional information look at these web sites:

• For bugs, patches, cvs access, ... use the SourceForge project website:
http://sourceforge.net/projects/agvsimulation.

• Website of the AGV simulation (currently under development): http:
//agvsimulation.sourceforge.net/.

• Short tutorial presentation, given by Alexan-
der: http://agvsimulation.sourceforge.net/files/
2005-11-16-Alexander-AGVsimulatorTutorial.ppt

• This User Guide in a single PDF file (remark: the User Guided is updated
frequently, so please regularly check the web site for changes): http:
//agvsimulation.sourceforge.net/files/UserGuide.pdf

• For more information about the research of the AgentWise taskforce:
http://www.cs.kuleuven.be/cwis/research/distrinet/public/
research/showgroup.php?NAME=agents
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